Lets try to get a deb package built

master
bbruns 12 years ago
parent 6af4394aa2
commit 1be646a4f3
  1. 3
      ChangeLog
  2. 4
      Makefile
  3. 2
      bin/firewall-sosdg
  4. 4
      debian/changelog
  5. 6
      debian/control

@ -1,3 +1,6 @@
0.9.14 - Brielle Bruns <bruns@2mbit.com>
-
0.9.13 - Brielle Bruns <bruns@2mbit.com>
- Fix location of ipv6 fi statement, moved to end of ipv6 rules
- Add default policy rules and IPV{4|6}_P{INPUT|OUTPUT|FORWARD} options

@ -1,4 +1,4 @@
VERSION=0.9.13
VERSION=0.9.14
TAR=/usr/bin/tar
TARBALL="firewall-sosdg-$(VERSION).tar.bz2"
@ -13,7 +13,7 @@ default:
tarball:
cd .. ;\
$(TAR) jcf $(TARBALL) --exclude='.svn' firewall-sosdg
COPYFILE_DISABLE=true $(TAR) vjcf $(TARBALL) --exclude='.svn' firewall-sosdg
upgrade:
mv -f blocked ipv4-blocked &>/dev/null

@ -18,7 +18,7 @@
# You should have received a copy of the GNU General Public License
# along with this program. If not, see <http://www.gnu.org/licenses/>.
FW_VERSION="0.9.13"
FW_VERSION="0.9.14"
# These option is here to help pre-1.0 users easily upgrade, defines critical defaults
# that would otherwise require remaking their options file. I leave this on by default,

4
debian/changelog vendored

@ -0,0 +1,4 @@
firewall-sosdg (0.9.14-1) stable; urgency=low
* Upstream build 0.9.14
-- Brielle Bruns <bruns@2mbit.com> Wed, 02 Mar 2010 21:00:17 -0700

6
debian/control vendored

@ -1,11 +1,11 @@
Package: firewall-sosdg
Version: 0.9.5-b1
Version: 0.9.14-1
Section: net
Priority: optional
Architecture: all
Architecture: any
Essential: no
Depends: iptables (>= 1.2.7), iproute, ${shlibs:Depends}
Pre-Depends: bash (>= 2.0) | dash
Pre-Depends: bash (>= 3.0) | dash
Suggests: conntrack, iptstate, fail2ban, dnsmasq
Maintainer: Brielle Bruns <bruns@2mbit.com>
Conflicts: ipkungfu

Loading…
Cancel
Save